Opened 8 years ago

Closed 3 years ago

Last modified 3 years ago

#726 closed defect (fixed)

nicotine crashed with TypeError in PopulateFilters(): value is of wrong type for this column

Reported by: anonymous Owned by: quinox
Priority: blocker Milestone: Release 1.3.0
Component: nicotine Version: 1.2.16
Keywords: Cc:

Description

see launchpad bug 732327

Attachments (1)

gtk_model_typeerror.patch (1.7 KB) - added by Pavel Rojtberg 8 years ago.

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by Pavel Rojtberg

Attachment: gtk_model_typeerror.patch added

comment:1 Changed 8 years ago by quinox

I'm not allowed to view that bug?

comment:2 Changed 8 years ago by quinox

Since I'm not allowed to view the original bug can you repost the stack trace? What part of the code is throwing the exception? It's great that you supplied a patch, but I'd like to try to reproduce the problem so I know the patch fixes it properly and correctly.

comment:3 Changed 8 years ago by quinox

I received word that this issue is caused by natty ubuntu, unstable GTK perhaps. I'll try to reproduce the problem

comment:4 Changed 8 years ago by anonymous

sorry, for the delay - did non leave an email adress.

here is the stack trace: (you should have access to that)

http: launchpadlibrarian.net/66025967/Traceback.txt

yes it happens in the ubuntu natty so its either the new gtk or python 2.7.

comment:5 Changed 8 years ago by anonymous

Thanks for the issue report, fixed with r1463

comment:6 Changed 8 years ago by anonymous

Probably related:

z@z:~/Documents/nicotine+$ ./nicotine.py
jeu. 10:11 Disabled UPnP support due to errors: Failed to import miniupnpc
          module: No module named miniupnpc. Also: Failed to run upnpc binary:
          Problem while executing command ['upnpc'] (1 of 1)
jeu. 10:11 Failed to import the Mutagen library, falling back to old library. To
          improve meta data please install Mutagen.
Kids: ['label8', 'downloaddir', 'portselection', 'label18', 'porthidden', 'upperport', 'label12', 'label10', 'labelnoshare', 'label17', 'hbox4', 'onlysharewithfriends', 'hbox1', 'hbox2', 'hbox3', 'vbox2', 'vbox3', 'vbox1', 'removeshares', 'vbox5', 'label19', 'sharepage', 'useupnp', 'warningclosedport', 'summarypage', 'username', 'label9', 'label16', 'label3', 'FastConfigureAssistant', 'label1', 'label2', 'lowerport', 'label4', 'label5', 'label6', 'label7', 'hseparator1', 'hseparator2', 'labelclosedport', 'shareddirectoriestree', 'password', 'portclosed', 'addshare', 'listenport', 'portpage', 'advancedports', 'userpasspage', 'checkmyport', 'portopen', 'welcomepage', 'warningnoshare']
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
jeu. 10:11 User miolands does not exist
Traceback (most recent call last):
  File "/home/z/Documents/nicotine+/pynicotine/gtkgui/frame.py", line 2122, in OnSettings
    self.settingswindow.SetSettings(self.np.config.sections)
  File "/home/z/Documents/nicotine+/pynicotine/gtkgui/settingswindow.py", line 2890, in SetSettings
    page.SetSettings(config)
  File "/home/z/Documents/nicotine+/pynicotine/gtkgui/settingswindow.py", line 479, in SetSettings
    self.shareslist.append([virtual, recode(actual), -1, actual])
TypeError: value is of wrong type for this column
Traceback (most recent call last):
  File "/home/z/Documents/nicotine+/pynicotine/gtkgui/frame.py", line 2122, in OnSettings
    self.settingswindow.SetSettings(self.np.config.sections)
  File "/home/z/Documents/nicotine+/pynicotine/gtkgui/settingswindow.py", line 2890, in SetSettings
    page.SetSettings(config)
  File "/home/z/Documents/nicotine+/pynicotine/gtkgui/settingswindow.py", line 479, in SetSettings
    self.shareslist.append([virtual, recode(actual), -1, actual])
TypeError: value is of wrong type for this column

comment:7 in reply to:  6 Changed 8 years ago by anonymous

Replying to anonymous:

Probably related:

Fixed with r1464

comment:8 Changed 3 years ago by gfarmerfr

Resolution: fixed
Status: newclosed

comment:9 Changed 3 years ago by gfarmerfr

Milestone: Release 1.2.17Release 1.3.0

Ticket retargeted after milestone deleted

Note: See TracTickets for help on using tickets.