Opened 8 years ago

Last modified 3 years ago

#677 new defect

BUG FOUND! Autojoin not working for "Public" room

Reported by: Detective John Kimble Owned by: quinox
Priority: normal Milestone: Release 1.3.0
Component: nicotine Version: 1.2.16
Keywords: Cc:

Description

Title says it all, not autojoined despite selecting autojoin. This leads to having to VIEW ROOM LIST and rejoin room each time running n+. (as there's no chat room command to join this room)

Change History (5)

comment:1 Changed 8 years ago by anonymous

It seems to work okay for most people. Do you get any errors on your console? After sthudown, are the rooms mentioned in ~/.nicotine/config on the line starting with the text "autojoin =" ?

comment:2 Changed 8 years ago by Detective John Kimble

Yes it is in the autojoin line - 'Public '

It does not work. anonymous are you saying that it works for you?

comment:3 Changed 8 years ago by anonymous

oh, like that. I thought you were talking about public rooms in general (as opposed to private rooms)

yeah joining that weird room probably doesnt work with auto-join, since its not a real room. I guess it's a bug. We can do two things:

1) make auto-join work with public room 2) disable the 'auto join' checkbox on the public room

You're asking for #1, we might implement #2. I haven't decided yet

comment:4 Changed 8 years ago by dyncAcoutty

thank you

comment:5 Changed 3 years ago by gfarmerfr

Milestone: Release 1.2.17Release 1.3.0
Note: See TracTickets for help on using tickets.