Opened 10 years ago

Last modified 7 years ago

#474 reopened defect

Nicotine fails at "Logged in, getting the list of rooms..."

Reported by: angelmarauder Owned by: quinox
Priority: normal Milestone: Release 1.3.0
Component: nicotine Version: 1.2.9
Keywords: Nicotine + fails Cc: no

Description (last modified by quinox)

That are the errors thrown when run in terminal. I tried removing and reinstalling but that didn't solve the problem I tried looking at transfers.py but I did not know what to do from there. It seems to be a null problem......hehe

Attachments (1)

Errors.odt (26.5 KB) - added by beefofantioch@… 10 years ago.
Errors included

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by beefofantioch@…

Attachment: Errors.odt added

Errors included

comment:1 Changed 10 years ago by quinox

Description: modified (diff)

The first line says "root@", I assume this is a joke or an error, you're not actually running n+ as root right?

Not directly related to the report, but 1.2.9 is fairly old. Please try 1.2.12 (there's an Ubuntu DEB on the front page)

To the point of your problem: The AttributeError? at the bottom is a result of the TypeError? in the middle of your output. I suspect that somehow your configuration file got corrupt. You can do two things:

  • Remove/rename the folder ~/.nicotine, for example with the terminal command "mv ~/.nicotine ~/.nicotine-broken". You will lose all your settings
  • Edit the file ~/.nicotine/config and look for the line "downloads = ". If you remove it Nicotine+ will probably start again. You will only lose your download list

If this helps you can attach the original corrupt config file to this report so we can make n+ more robust (do remove your username/password and anything else you might not want to share).

comment:2 Changed 10 years ago by quinox

Resolution: invalid
Status: newclosed

Suggested steps to solve the problem were never performed (or no feedback was given), lack of activity from original submitter.

comment:3 Changed 8 years ago by troche@…

Resolution: invalid
Status: closedreopened

I have this same issue. I attempted your solution but was met with the same result. Program is still responding but it seems unable to communicate with the server beyond the login.

comment:4 Changed 7 years ago by infarveimminc

How do you think, who this year won the Champions League Cup?

comment:5 Changed 7 years ago by bewmyers@…

I'm new to Ubuntu, familiar with Soulseek on Windows, and having the same problem. I'm using N+ 1.2.16, Ubuntu 12.04 LTS. If I can post any other relevant info, let me know. I'm still getting familiar with Ubuntu and really enjoy the freedom, but the wealth of information is challenging.

When I initially installed Nicotine+ it was working fine: I was connected and downloading. I realized I wasn't sharing my music folder, so I set that to share. The program froze upon that change, and I can only change settings now offline. If I am connected to the internet N+ will freeze on "...getting list of rooms..." but if disconnected I can change settings and use the menus. I have unshared my files and also removed and reinstalled Nicotine+. I don't know if there is a cleaner uninstall I could perform or if it's port-related, etc. I can provide more information, and will respond to questions better than the previous posters.

Note: See TracTickets for help on using tickets.